"left indicator malfunction"

All Volvo XC40 related discussions
JFDIT
Posts: 1169
Joined: Tue Sep 28, 2021 5:21 pm

Post by JFDIT »

Chris, I've had that happen once. Quite possibly software.
XC40 MY24 B4 Ultimate Dark, Black Leather, Crystal White, 20" Rims
Lincolnshire England.

ChrisLF
Posts: 1314
Joined: Wed Apr 24, 2019 8:21 am
Location: Heart of England

Post by ChrisLF »

Thanks, unless it starts happening more frequently it's not much of a problem.
2023 B4 Plus Dark FWD in Silver Dawn. Tinted Rear Windows. Spare Wheel & Tow Bar dealer fitted.

Gone - 2019 T4 R-Design FWD in Bursting Blue. Winter & Convenience Packs, Power Seat, Front Park Assist, Rear Camera, Spare Wheel & Tow Bar.
RonFleet
Posts: 142
Joined: Sun Aug 16, 2020 4:48 pm
Location: Hampshire

Post by RonFleet »

This has occurred twice since I collected my car a few weeks ago. I'm waiting to see if it becomes a regular issue or disappears with the next software update.
Cheers,
Ron

XC40 B3 Plus Automatic
Fjord Blue
JFDIT
Posts: 1169
Joined: Tue Sep 28, 2021 5:21 pm

Post by JFDIT »

Could be worse, the indicator leaver fell off my new land rover a few years back!
XC40 MY24 B4 Ultimate Dark, Black Leather, Crystal White, 20" Rims
Lincolnshire England.
ChrisLF
Posts: 1314
Joined: Wed Apr 24, 2019 8:21 am
Location: Heart of England

Post by ChrisLF »

RonFleet wrote: Sun Oct 22, 2023 6:45 pm This has occurred twice since I collected my car a few weeks ago. I'm waiting to see if it becomes a regular issue or disappears with the next software update.
My thoughts as well as seems to be a common issue.
2023 B4 Plus Dark FWD in Silver Dawn. Tinted Rear Windows. Spare Wheel & Tow Bar dealer fitted.

Gone - 2019 T4 R-Design FWD in Bursting Blue. Winter & Convenience Packs, Power Seat, Front Park Assist, Rear Camera, Spare Wheel & Tow Bar.
Newswitcher
Posts: 12
Joined: Mon Sep 04, 2023 4:51 am

Post by Newswitcher »

I've been getting this issue intermittently on my 2 month old car too - first time was on day of collection and had it a few times since, but like others it seems to disappear within seconds. Seems to be really random and doesn't seem to happen at any specific time or action, which is plain annoying. Had dealer look at it after the first month and they did a full software reinstall, but hasn't solved the problem.
XC40 MY24 B4 Ultimate Dark, Blond Leather, Crystal White, 20" Rims
ChrisLF
Posts: 1314
Joined: Wed Apr 24, 2019 8:21 am
Location: Heart of England

Post by ChrisLF »

Volvo need to address this.

Not old enough yet obviously, but I wonder what would happen if it occurred during an MOT?
2023 B4 Plus Dark FWD in Silver Dawn. Tinted Rear Windows. Spare Wheel & Tow Bar dealer fitted.

Gone - 2019 T4 R-Design FWD in Bursting Blue. Winter & Convenience Packs, Power Seat, Front Park Assist, Rear Camera, Spare Wheel & Tow Bar.
VloMo
Posts: 55
Joined: Mon Sep 11, 2023 11:06 am

Post by VloMo »

I’m sure there is a working , it’s not , it’s working , not indicator joke that would cover you for the mot.

But you’re right a mot examiner could have grounds for a fail. I’ll keep an eye on mine. I had a minor fault on my vw I let slide at the time and now it’s more of an issue.
AldridgeAndy
Posts: 22
Joined: Sun Nov 12, 2023 1:08 am

Post by AldridgeAndy »

I experienced “left indicator malfunction” driving my new car home from collection two weeks ago. Then the issue never appeared again so I assumed maybe someone has been over confident with the jet wash preparing the car.

Tonight I had an issue with navigation reporting it could not obtain GPS. So once safely parked I rebooted the head unit which restored navigation. It also brought back the “left indicator malfunction” message.

As it’s looking like a software issue more than anything else, can over the air updates fix this sort of thing, or are they solely for Google automotive?
2024 MY - Volvo XC40 B3 Plus Dark
eugen61
Posts: 1160
Joined: Sun May 10, 2020 7:33 am

Post by eugen61 »

AldridgeAndy wrote: Sun Nov 12, 2023 1:18 am As it’s looking like a software issue more than anything else, can over the air updates fix this sort of thing, or are they solely for Google automotive?
This is a specific AAOS bug and could be fixed by Volvo with OTA update. Is your car running on the latest software version 2.12 ?
Post Reply